View Issue Details

IDProjectCategoryView StatusLast Update
0009365New issuesClientpublic2018-09-05 02:38
ReporterBeaTzZAssigned Tomyonlake 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionduplicate 
PlatformPCOSWindowsOS Version10 x64 Prof
Summary0009365: Marker dont always appear when created
Description

Markers dont always appear when created, made a brake light script that shows it perfectly:
http://pastebin.com/HN666vEL

brake a few times, sometimes the markers get created, sometimes one is missing and sometimes both, cannot reproduce when exactly that happens.

Steps To Reproduce

Load the script i provided and brake a couple of times, seems to be client sided.

TagsNo tags attached.

Relationships

related to 0007983 closed New issues Corona markers often not appearing or only a few 
child of 0009393 resolvedlopezloo Multi Theft Auto : San Andreas Corona markers has wrong attach offset position 

Activities

qaisjp

2016-09-05 22:18

administrator   ~~0025140

Does this occur on a server with just one player (you)?

BeaTzZ

2016-09-05 23:46

viewer   ~~0025141

Last edited: 2016-09-05 23:52

View 2 revisions

have not tested that, but there shouldnt really be a difference as its all client sided.

oh, and another resource on the community suffers from the same issue, its called "emerlights" or similiar, i forgot it, it uses coronas too.

codylewiz

2016-09-06 00:01

viewer   ~~0025142

Coronas have issues displaying sometimes.

Try using this for the lights.

https://community.multitheftauto.com/index.php?p=resources&s=details&id=9558

BeaTzZ

2016-09-06 00:13

viewer   ~~0025143

@codylewiz you cannot attach those to an object, which makes my script pretty much unusable.

arranTuna

2016-09-06 00:16

manager   ~~0025144

Those steps to reproduce are a bit big, it's better if you can get a tiny snippet of code that reproduces it because there might be a bug in the script.

qaisjp

2016-09-06 00:20

administrator   ~~0025145

BeaTzZ, I'm asking because the on-screen marker limit may have been reached. Although that will usually cause flickering instead.

BeaTzZ

2016-09-06 00:31

viewer   ~~0025146

1) arranTuna, create a resource and copy the source in there, launch it, and i didnt find any bugs when checking trough it, and a friend who helped didnt either

2) qaisjp I'm not sure, my server doesnt use many coronas, but it could be

BeaTzZ

2016-09-06 00:45

viewer   ~~0025147

Update: Im using custom_coronas resource now, but the bug itself still exists.

codylewiz

2016-09-06 02:05

viewer   ~~0025148

Last edited: 2016-09-06 03:02

View 2 revisions

-- First of all, use onClientRender or setTimer to set their positions --

Does the bug appear when using custom coronas or not?

If so; it's a bug with your code

If not it's due to the regular coronas being really glitchy
(I've had similar issues)

BeaTzZ

2016-09-06 09:28

viewer   ~~0025149

Last edited: 2016-09-06 10:36

View 2 revisions

yes, custom_coronas work fine, the issue seem to appear when normal coronas are "near eachother" if that makes sense that some dont appear, atleast thats the only way i can reproduce it

codylewiz

2016-09-06 12:10

viewer   ~~0025150

Normal coronas are extremely glitchy, this bug has been around for a while

arranTuna

2016-12-27 16:44

manager   ~~0025567

Need new steps to reproduce.

Inspirator

2016-12-27 23:38

viewer   ~~0025579

Same issue https://bugs.multitheftauto.com/view.php?id=7983

lopezloo

2017-04-28 01:40

developer   ~~0025852

This may be same issue as #9393 which got fixed. Needs testing & feedback.

Issue History

Date Modified Username Field Change