View Issue Details

IDProjectCategoryView StatusLast Update
0008964Multi Theft Auto : San AndreasServerpublic2016-12-14 12:04
ReporterJBoyAssigned Tosbx320 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionunable to reproduce 
PlatformOSWindowsOS Version10
Product Version 
Target VersionFixed in Version 
Summary0008964: Server full screen'd causes it to crash
Description

Because of some weird update with Windows 10, server owners now have the ability to resize the server's console. This doesn't show any issues at the moment until you full screen the window.

When full screening the server console, the server will crash instantly.

Steps To Reproduce

Start the server, full screen the console and well.. magic!

Additional Information

Server version is: MTA:SA Server v1.5-release-7376. No crash logs are being created. Running it through debug points the crash being in the core.dll with error: Unhandled exception at 0x0000000180016380 (core.dll) in MTA Server64.exe: Stack cookie instrumentation code detected a stack-based buffer overrun.

TagsNo tags attached.

Relationships

related to 0008965 resolvedJusonex Server FPS / Players not showing in MTA Console 

Activities

JBoy

2015-07-30 05:42

viewer   ~~0023751

Crash doesn't occur if you change the font size.

sbx320

2015-08-05 16:38

administrator   ~~0023826

Unable to reproduce with r7392.

Can you retest this issue?

qaisjp

2015-08-13 18:31

administrator   ~~0023922

Last edited: 2015-08-13 18:32

View 2 revisions

This issue is seemingly random to reproduce, but you definitely need legacy console disabled.

When I confirmed this issue I was on a 1920x1080 local session with a single screen. (suggestion by sbx for the single screen distinction)

Right now I am RDP'd into my same computer with a single 1280x800 screen and cannot reproduce this issue.

I'll try and see if I can reproduce this issue once I am at home.

qaisjp

2016-01-24 17:04

administrator   ~~0024348

I cannot reproduce this anymore

Issue History

Date Modified Username Field Change