View Issue Details

IDProjectCategoryView StatusLast Update
0008685New issuesScriptingpublic2014-12-20 21:04
ReporterJBoyAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Summary0008685: destroyElement causes player to be deleted
Description

When using destroyElement on a vehicle while the player is exiting it, the vehicle AND player is destroyed. The player has to restart his client in order for him to play again.

Steps To Reproduce

Create a vehicle and define it with a var.
Bind a code to destroy the vehicle
Exit the vehicle, and as you're exiting, destroy the vehicle.
Player should now be deleted along with the vehicle, forcing you to be stuck.

TagsNo tags attached.

Relationships

duplicate of 0008629 resolvedccw Multi Theft Auto : San Andreas Destroying vehicle when exiting it causes issues 

Activities

lopezloo

2014-12-20 19:35

developer   ~~0022705

#8629

AboShanab

2014-12-20 19:44

viewer   ~~0022706

i can confirm it.
try this code.
srun addCommandHandler("xTestBug",function (player) local x,y,z = getElementPosition(player) a = createVehicle(411,x+3,y,z) warpPedIntoVehicle(player,a) bindKey(player,"k","down",function(player) destroyElement(a) end) end)
but see this
https://bugs.multitheftauto.com/view.php?id=8629

Issue History

Date Modified Username Field Change