View Issue Details

IDProjectCategoryView StatusLast Update
0008535Multi Theft Auto : EditorMap Editorpublic2014-09-22 17:55
Reportereinheit-101Assigned ToarranTuna 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0008535: Map Editor does not always increase object IDs after creation
Description

This error occurs mostly if one does create very many objects of the same type with cloning. The map editor does not update the IDs or the IDs dont get correctly saved, which leads to a very annoying issue because suddenly 100s of objects have the same ID.

I wonder why nobody has reported this yet, because it is an old bug.

Steps To Reproduce

-Create an object like 1685
-Clone it sometimes
-Save map
-Re-Open map
-Clone it again sometimes
-Save again
-Re-open map again
-Open "Current Elements" browser
-The objects cloned after the re-opening have all the ID "1"

TagsNo tags attached.

Activities

einheit-101

2014-09-15 00:39

reporter   ~~0022018

Here is a picture, showing the problem.
http://i.imgur.com/L3dfcez.jpg

Inspirator

2014-09-18 09:43

viewer   ~~0022025

Have the same issue from time to time. Annoying because sometimes you can't select the object from the element browser because it doesn't know which one of the objects you mean. Also annoying because you will lose count when placing certain objects or spawnpoints.

einheit-101

2014-09-18 11:42

reporter   ~~0022027

Exactly what i'm talking about.

arranTuna

2014-09-22 17:55

developer   ~~0022039

These objects weren't getting the "id" element data set and that is what is saved to the map file, so it was saving duplicate IDs even though element browser said it was right because that must use a different element data.

Fixed in https://code.google.com/p/mtasa-resources/source/detail?r=1015

Issue History

Date Modified Username Field Change