View Issue Details

IDProjectCategoryView StatusLast Update
0007624New Feature Requests[All Projects] Generalpublic2018-11-13 22:12
ReporterTAPLAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Summary0007624: Auto reconnect
Description

Instead of the annoying message that appear when you lost the connect with the server

i would suggest a feature that will automatically reconnect you to the server again after a countdown or something like this.

TagsNo tags attached.

Activities

Dutchman101

2013-05-15 19:10

updater   ~~0018576

Nice, this can avoid (new) players starting to look for another server/quitting directly after disconnect, as example if that's faster to get back to gameplay/if they cannot find the disconnected server because new players might not know where to look at recent servers.

This happened alot to my own server: Quick restart and all (as explained, new) players will not connect anymore. But if it auto-reconnect then it doesnt cost time for them to connect again, and also the server playercount on restart might be more constant.

x86

2013-05-16 16:35

administrator   ~~0018577

Nice request, but I'd say: show a popup like: "Disconnect <reason_here>. Would you like to reconnect ?".

Dutchman101

2013-05-16 21:52

updater   ~~0018578

Last edited: 2013-05-16 21:53

@ x86 Indeed, better to prompt. But add a reconnect interval of 10 seconds or something because if a server restarts, it needs some time to start up and accept connections again. Without interval, players would directly reconnect when prompted and get a timed out message again since the server is still in the restart process.

Edit: Something like, reconnecting in [seconds] after the prompt.

Issue History

Date Modified Username Field Change