View Issue Details

IDProjectCategoryView StatusLast Update
0007550Multi Theft Auto : EditorMap Editorpublic2013-05-08 12:13
ReporteraLeKS_007Assigned ToarranTuna 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindows 7OS Version
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0007550: Map Editor shouldn't overwrite script lines in meta.xml
Description

meta.xml E

Map Editor always delete strings like this: <script src="client.lua" type="client"></script>

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 1

2013-04-06 18:40: aLeKS_007 (EUR 1)
Users sponsoring this issue (Total Sponsorship = EUR 1)

Activities

Woovie

2013-03-27 20:29

manager   ~~0018292

Because the map editor is rewriting the entire meta.xml every time you save. Just have your map save under a different name and copy the map file over to the resource you want it to load with.

aLeKS_007

2013-03-27 21:08

viewer   ~~0018293

it is very inconvenient to do this EVERY map test. All was good in the early versions of editor

arranTuna

2013-03-27 21:12

developer   ~~0018294

Make a patch for map editor, that lets you add lines to the meta.xml

Talidan

2013-03-27 21:18

administrator   ~~0018295

It seems like a valid bug report. The editor was always intended to leave parts of a resource intact, even if they're not a map resource

arranTuna

2013-03-27 21:28

developer   ~~0018296

The part of map editor that writes the meta.xml would need to look at the existing meta.xml and find these lines.

aLeKS_007

2013-03-27 21:30

viewer   ~~0018297

Yes

Talidan

2013-04-06 18:45

administrator   ~~0018325

Could we simply not edit meta.xml's and not replace it? It's a matter of removing any <map/> tags and appending a new one, adding relevant settings and metadata, then leaving everything else intact.

castillo14

2013-04-14 21:24

viewer   ~~0018343

Last edited: 2013-04-15 01:24

This small patch will remove only the scripts that has to be added by the editor ( extension files ) and will leave any other script intact.

Link: http://www.mediafire.com/?fo0tr9f78y37q6z

aLeKS_007

2013-04-17 10:08

viewer   ~~0018357

Great job castillo14 :) All works, thank you

aLeKS_007

2013-04-19 13:29

viewer   ~~0018367

Sorry for the sponsorship, I can't delete this and I can't pay

arranTuna

2013-05-02 11:57

developer   ~~0018465

Patch applied in http://code.google.com/p/mtasa-resources/source/detail?r=927

aLeKS_007

2013-05-07 21:29

viewer   ~~0018530

thank you

Issue History

Date Modified Username Field Change