View Issue Details

IDProjectCategoryView StatusLast Update
0007425Multi Theft Auto : EditorMap Editorpublic2013-04-10 21:44
ReporterkakakskAssigned ToarranTuna 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version8
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0007425: Make objects, created by editor, have LOD model preinstalled
Description

I am not sure, if this is related to editor, but anyways I post it, because it would be great, if the custom objects in mta had a LOD model attached to it already. Now we create custom objects and they can't be seen from long distance without doing hard job to make every LOD model and attach it to every custom object.

Steps To Reproduce
  1. Create custom object
  2. Go out of the object HD distance.
  3. Custom object disappears.
TagsNo tags attached.

Activities

arranTuna

2012-11-15 12:42

developer   ~~0017864

Last edited: 2013-04-06 18:28

Using the new scripting extension file and creating an extra attribute for objects, this could be implemented without map file support. I think the only way that we can get the LOD of an object is with processLineOfSight too.

If MTA can get the LOD of an object, does it have a list of objects to LODs, or a function that can be made available to get LOD ID from object ID?

arranTuna

2013-04-07 14:54

developer   ~~0018326

I made a script that would get the LOD with processLineOfSight but after reading the wiki page and testing it, it turns out you can only get the LOD ID of a world object, not a created object, therefore I'm unable to create a LOD list.

sbx320

2013-04-09 03:53

administrator   ~~0018327

Last edited: 2013-04-09 13:17

LOD List: http://sbx320.net/mta/lodmap.lua (Key = Model Value = LOD Model)

Parsed that from the INST block of the GTA IPLs with a quickly built IPL parser in Lua. This does not include Binary IPLs, but 1404 objects should be a good start.
IPL Parser: http://sbx320.net/mta/lodgen.lua

Edit:
Seems that binary IPLs can't contain LOD information anyway, so this list is likely to be complete.

arranTuna

2013-04-09 16:22

developer   ~~0018329

Nothing in that list works and objects that are totally different have the same LOD model in that list.

sbx320

2013-04-09 17:05

administrator   ~~0018330

Sorry, messed up with the parsing. The lod entries in the inst block are actually offsets in the current block and not model ids.

Fixed LOD List: http://sbx320.net/mta/lodmap.lua

arranTuna

2013-04-09 17:35

developer   ~~0018331

Thanks for the list, fixed in http://code.google.com/p/mtasa-resources/source/detail?r=920

Issue History

Date Modified Username Field Change