View Issue Details

IDProjectCategoryView StatusLast Update
0007294New issuesClientpublic2012-10-22 15:51
ReportervEnom.skAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0007294: Black screen when restoring MTA window in interior different than 0
Description

In some interiors like CJ's house, screen stays black after minimizing and restoring MTA window, no input is working.

Tested in latest nightly.

TagsNo tags attached.

Relationships

child of 0004647 resolvedccw Multi Theft Auto : San Andreas Stability errors (random texture swapping/assertions) after alt+tab 

Activities

ccw

2012-09-02 22:03

administrator   ~~0017436

Can't reproduce this.
Exact steps please.

TreN

2012-09-21 13:25

viewer   ~~0017609

Last edited: 2012-09-21 15:40

  1. Start interiors resource
  2. Teleport to Groove Street, near CJ's house (for example)
  3. Enter CJ's house
  4. When in interior, minimize and then restore (alt-tab)
  5. You'll get black screen

CWanted

2012-09-21 20:04

updater   ~~0017611

  1. Minimize and restore again.
  2. MTA will crash.
    http://rghost.net/40500558

TAPL

2012-09-21 22:45

viewer   ~~0017612

Last edited: 2012-09-21 23:06

I can confirm this issue, i got black screen, "Esc" doesn't work, i can hear my move sound, i can shoot with weapon and the sound working, i can even write in chat and i see it in Console.

if "Settings > Video > Windowed" is enabled, the screen won't be black, but it will frozen, "Esc" doesn't work, i can hear my move sound, i can shoot with weapon and the sound working, i can even write in chat and i see it in Console.

MTA crash after i out from CJ house.

arranTuna

2012-09-21 22:52

manager   ~~0017613

Last edited: 2012-09-21 22:55

I didn't get it in ammunation but I got it in CJ's house.

I managed to exit the interior and my screen became visible again but it's got some strange stuff that looks like text and another time I was able to maximize successfully while still in the interior and what looked like a transparent window texture was covering my screen.

Maccer

2012-09-21 23:10

viewer   ~~0017614

Related:
http://bugs.mtasa.com/view.php?id=4647
http://bugs.mtasa.com/view.php?id=4922

arranTuna

2012-09-22 00:12

manager   ~~0017615

I tried setting their interior to 0 to fix one of those bugs with scripting the minimized event and didn't work, perhaps it can be accomplished in MTA code?

Hack fix would be recreating these interiors with mapping but that's a lot of work and would only work with editing all the scripts.

Issue History

Date Modified Username Field Change