View Issue Details

IDProjectCategoryView StatusLast Update
0006620Multi Theft Auto : San AndreasClientpublic2016-04-08 13:22
ReporterMaccerAssigned To 
PrioritynormalSeveritytrivialReproducibilityN/A
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0006620: Console is spammed when pressing a disabled MTA key
Description
  • So basically, the third parameter which is set to true is supposed to disable MTA Controls such as chatbox, voiceptt, and enter_passanger.

  • It works, but when you attempt to push any of the MTA Multiplayer keys, the console spams: Unknown command or cvar: chatbox

  • As an added related bug, when you re-enable all controls, and you appear to be holding enter while the script re-enables them, the control immediately takes effect.

  • Basically if I was holding enter when I re-enabled controls, GTA will register enter and my character will start sprinting towards the nearest car.

  • Somehow our MTA chatbox manages to avoid this.

TagsNo tags attached.

Relationships

duplicate of 0009165 closed Enabling a control whilst the control is held down will trigger the control 
duplicate of 0009166 resolvedccw Console displays an error message when pressing the key of a disabled MTA control 

Activities

arranTuna

2014-11-10 20:37

manager   ~~0022315

crun toggleControl("chatbox", false)
Press your chat key
Open console
"Unknown command or cvar: chatbox"

qaisjp

2014-11-10 20:41

administrator   ~~0022316

Last edited: 2014-11-10 20:41

View 2 revisions

An easy fix for Arran's post above is to not lot toggleControl work with chatbox, chatbox should just be treated as a command bound by bindKey.

einheit-101

2016-02-25 20:19

reporter   ~~0024462

These "Unknown command or cvar:" debug outputs should be disabled / deleted. They arent even useful and just spam the console when i disable the "enter_passenger" control.

Issue History

Date Modified Username Field Change