View Issue Details

IDProjectCategoryView StatusLast Update
0005702New issuesClientpublic2017-05-26 16:19
ReporterDevan_LTAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0005702: Setting vehicle door state to 1 closes the door
Description

If the vehicle is streamed in and you set its door state to 1, that will have the same effect as setting the state to 0: the door doesn't open. In contrast, if you set vehicle door state to 3, it may look closed, but actually its rotation isn't fixed and gravity or movement of the vehicle can open it. The same should happen with door state 1, but it doesn't. getVehicleDoorState may return 0 or 1, but the actual state is the same.

Steps To Reproduce

In runcode:
/run car=createVehicle(411,0,0,3)
/run setVehicleDoorState(car,2,1)
Rotation of the left door is fixed, even though it shouldn't be.
/run setVehicleDoorState(car,2,3)
Rotation of bashed door isn't fixed, it can swing, just like it should in this state.

Additional Information

Tested on 1.1 nightly builds 2117 and 2143

TagsNo tags attached.

Relationships

duplicate of 0004185 closedlopezloo Multi Theft Auto : San Andreas Door States 1 and 3 need a “love tap” or should make the door unclosable 

Activities

ryden

2010-12-23 10:57

manager   ~~0012347

Last edited: 2010-12-23 10:58

Get into the vehicle to let it swing free. Currently, vehicle doors are only let to swing (in 1.1) when you are the driver of the vehicle. That door state means that it's broken enough to not be able to stay closed.

Close issue maybe?

Devan_LT

2010-12-23 12:36

viewer   ~~0012349

I got into the vehicle and door still didn't swing free. What's the point of fixing door rotation if there's already state 0 for doing that?

Issue History

Date Modified Username Field Change