View Issue Details

IDProjectCategoryView StatusLast Update
0005478Multi Theft Auto : EditorMap Editorpublic2010-07-19 13:24
ReporterGamesnertAssigned ToGamesnert 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0005478: Slightly oversized patch for the map editor
Description

Changelist:

  • Added a basic (and hacky) permissions system
  • Made sure events, commands and keybinds from EDF resources are automatically unloaded on stop (might need some more testing, now I think of it)
  • Made sure EDF scripts aren't sent when a player joins in test mode
  • Made sure EDF scripts are only sent to the player who actually needs them when a player joins
  • Made the onStop function work server-side as well
  • Made sure gamemodes are stopped when the editor starts, to prevent mapmanager from starting resources as a gamemode when a gamemode EDF is loaded
  • Reduced warningspam in editor_gui
  • Made sure wave height now works with decimals as well
  • Fixed a bug where an EDF which doesn't add elements would show up when scrolling through EDFs, but wouldn't allow for scrolling past it (with the mousewheel at least)
  • Fixed a bug where if you would do outputMessage before another message disappeared, the second message would disappear too soon
  • Commented dimension stuff in editor_gui (what is dimension stuff doing in a GUI resource anyway?)
  • Made sure that the onClientRender thing in editor_main -> main.lua doesn't run while test mode is enabled
  • Created an integrated blips system for the map editor, because without, mapping with multiple people would barely be possible anyway
  • Made map loading use coroutines, so the server doesn't hang until it suddenly thinks it's funny and tries to say that the script is taking too long (possibly fixes #5463)
  • Made F5 start the last used test mode, so if you're constantly trying to test a race, you actually end up in the right mode when pressing F5
  • Made the editor respawn all players when the test mode is ending. This appears to be fixing so much that I won't be listing them all here, but it fixes stuff like camera screwups when exiting the test mode while in a vehicle, and having a weapon in your face when exiting testing with a weapon in your hands
  • Fixed players joining the map editor not being spawned, if test mode was started at least once (g_in_test was never reset)
  • Fixed dropped elements being added to undo/redo as "moved", while they haven't moved at all
  • Probably some other stuff, was too lazy to write down all the stuff I fixed while I fixed it

I know I should have sent the fixes as individual patches, but I kind of forgot to do so. And by the time I noticed it might have been a good idea, well, that was right when I made this post, actually.

TagsNo tags attached.

Relationships

related to 0005398 resolvedGamesnert Mouse messed up on stopping test-mode while in a vehicle 
related to 0005405 resolvedGamesnert Joining in the map editor sometimes spawns you in the wrong dimension 
related to 0004048 closed [Request] Add a permissions system 
related to 0005463 resolvedGamesnert Huge maps in the mapeditor don't load completely 

Activities

x86

2010-07-19 13:24

administrator   ~~0011778

Last edited: 2010-07-19 13:26

Applied in: http://code.google.com/p/mtasa-resources/source/detail?r=622

Issue History

Date Modified Username Field Change