View Issue Details

IDProjectCategoryView StatusLast Update
0005228Multi Theft Auto : San AndreasGeneralpublic2018-09-02 20:34
ReportermrdejongAssigned ToTalidan 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005228: GNU gettext for Lua
Description

I'm really looking forward too see the feature gettext in mta server and client side.

Gettext is a nice transelation system. With this it would be posible to transelate resources in every native language.

Yes it is posible to do it with xml and stuff. But it is nicer todo it with gettext, for example:

[code]
guiCreateLabel(10, 10, 100, 20, _('I can be transelated.'), false);
[/code]

Yes, i know it is also posible to create a server side module for it, but then i ain't have the functions in the client side.

TagsNo tags attached.

Relationships

parent of 0008141 resolvedccw Multi Theft Auto : San Andreas Hungarian MTA 1.4 client design, layouts bug 
parent of 0008140 closed New issues Hungarian translation is not well coded 
parent of 0008136 closed New issues Some graphical defects in L10n 1.4 
parent of 0008156 resolvedccw Multi Theft Auto : San Andreas GUI fail in Interface in german 
has duplicate 0008134 closed New issues Add finished translations to client 
related to 0008185 resolvedTalidan Multi Theft Auto : San Andreas [Request] Function to get player's localisation setting 

Activities

Talidan

2010-03-06 02:24

administrator   ~~0011123

If you have the technical capability you could try submitting a patch to be implemented.

mrdejong

2011-02-16 13:33

reporter   ~~0012947

That is going to be very difficult. Since my c++ experience ain't that high. I'm going to make a module first, since that is maybe the best way to do it and learn how to.

Talidan

2011-02-16 14:19

administrator   ~~0012948

We're actually implementing this internally now, more on that soon :)

CWanted

2014-01-12 13:28

updater   ~~0019977

Last edited: 2014-01-12 13:48

View 3 revisions

https://code.google.com/p/mtasa-blue/source/browse/#svn%2Fbranches%2FL10n
http://forum.mtasa.com/viewtopic.php?f=31&t=59499
Needs target version (1.4?).

Issue History

Date Modified Username Field Change