View Issue Details

IDProjectCategoryView StatusLast Update
0005054New issuesClientpublic2009-10-12 15:15
ReporterMaccerAssigned To 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionduplicate 
Summary0005054: Assertion Failure (Most Likely Collision Related)
Description

So there's a bug in this gamemode... but that doesn't matter.

So I spawned, but my vehicle was collisionless (disabled by a function), since the bug existed. So I just decided to spin around since things without collision did not apply to the law of gravity.

Eventually, my car model started to transform and skew as expected, but then I get an assertion failure, assuming it has something to do with the collision system.

Steps To Reproduce

Get a car, disable it's collsion.
Spin around by putting weight on it by moving forward, turning left, etc.
Wait for it to start deforming and keep doing it until you get an error.

Additional Information

The gamemode was CAW on some server. It's a buggy and lite but working version of Interstate 64.

TagsNo tags attached.

Relationships

duplicate of 0005040 resolvedccw Multi Theft Auto : San Andreas C++ Assertion failed error on click 

Activities

Maccer

2009-10-12 01:17

viewer   ~~0010688

I don't have a dump file for this since the application refused to abort or ignore. I had to forcefully kill it.

ccw

2009-10-12 15:15

administrator   ~~0010689

  1. The assert has been fixed for 1.0.2
  2. As you say, using setElementCollisionsEnabled(false) to disable the collision of a vehicle controlled by the local player, can cause transform and skew weirdness. The only way round that is to disable the vehicle physics by using setVehicleFrozen(true) at the same time.

Issue History

Date Modified Username Field Change