View Issue Details

IDProjectCategoryView StatusLast Update
0004381Multi Theft Auto : EditorGeneralpublic2011-07-28 21:55
Reporter[RTS]SATANAssigned ToarranTuna 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0004381: Can't change the position of an object any longer.
Description

I'm currently workin on Chinatown Map, when it was nearly finished, i accidently double right-clicked on a building, so it became attached to the cursor, after that i left-clicked one time so it was not longer attached to the cursor and placed in the air.
Ok no problem so far, i just placed the building were it was before and saved the map, then i reopened the map and the building was back in the air again.
I tought "ok must be my fault .. i propbably did something wrong",i placed the object again were it was and saved and re-opened the map.
..and there you go, it's back in the air again.
after that i've tryed serveral things like copying the building , deleting it, saving the map under a different name etc etc .. but nothing worked, it always back in the air.

TagsNo tags attached.

Activities

scarface1994

2009-05-28 11:09

viewer   ~~0009419

Happened to me too but it's quite random.

[RTS]SATAN

2009-05-28 14:47

viewer   ~~0009420

Last edited: 2009-05-28 14:57

btw this happens to every new object i try to place, which means that i can't finish my map.

Talidan

2009-05-28 15:54

administrator   ~~0009422

Do you mind sending me your map (if it happens every time with this specific map?).

If not, i need a way to reproduce this

[RTS]SATAN

2009-05-28 16:39

viewer   ~~0009424

Last edited: 2009-05-28 16:39

it also happended on other maps and i fixed it by reopening the map...but like i said, this time it doesn't work.

ps. i'll send you the map via pm on mta forums.

Talidan

2009-05-28 21:39

administrator   ~~0009428

I tried, but i was unable to reproduce. Are there a certain fixed number of steps you can do to perform it?

scarface1994

2009-05-29 00:10

viewer   ~~0009429

Not really, all I can suggest is to play around with maps until it happens =/

Talidan

2009-06-22 00:21

administrator   ~~0009669

Can you actually check if the .map is being written to, and the positions are correct when this bug happens?

It will be useful to determine whether the Opening code is causing this, or the Saving code.

arranTuna

2011-07-28 21:05

developer   ~~0014042

While adding trains I experienced this problem.

Its actually if you have the element seleceted when you save that it doesn't save correctly. I'll have a go at this one now.

Picard

2011-07-28 21:54

updater   ~~0014043

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-resources/source/detail?r=757 )

Issue History

Date Modified Username Field Change