View Issue Details

IDProjectCategoryView StatusLast Update
0004246Multi Theft Auto : San AndreasClientpublic2018-09-06 07:17
ReporterCazomino05Assigned To 
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0004246: Vehicle entry bug in skimmer/seasparrow/leviathon etc
Description

Vehicle entry in these vehicles when your player is on land seems to cause problems in which your player gets stuck in water and when this happens your also unable to attempt to re-enter this vehicle, Or any vehicle for that matter until you go to land at which point you receive the network trouble message and get warped back to the vehicle.

Additional Information

I've reverted back to vehicle warping at the moment but ideally we should not need it as it would require warping to support jacking and is visually not as good.

to re-enable vehicle entry without warping just comment out the line
bWarpIn = true;
in CGame.cpp in the server deathmatch solution.

TagsNo tags attached.

Relationships

related to 0006469 closed Falling into water while attempting to enter a vehicle problem 
related to 0004157 resolvedCazomino05 Getting into Skimmer stops Jump from working if you fall into water instead of getting in. 
related to 0002733 resolvedJax trying to enter boats or skimmer causes a glitch 
related to 0007908 resolvedccw Cannot enter any vehicle after trying to enter a vehicle in water 
related to 0006233 closed Network trouble caused by an object blocking player vehicle entry 

Activities

R3mp

2009-07-19 18:21

viewer   ~~0010034

This happens with all vehicles. If you try to enter a vehicle as passenger then fall into water you will be unable to jump, when you reach land you will get the network trouble message, be warped back and everything will work normally again

This is especially prevalent with helicopters in the heligrab resource and is a real pain, often requiring /kill or reconnect (or admin intervention) if no land is nearby

see http://remp.sparksptpm.co.uk/mta/vehicle_enter_jump.mp4 for a video of it happening with a car, reproducable every time (notice in the chat i try to enter the vehicle as i fall past it ("vehicle start enter"))

also related to 4157 and 2733

Cazomino05

2014-06-14 21:29

reporter   ~~0021028

Your video has been deleted but I was able to reproduce via the steps you provided, I am looking at it now

qaisjp

2018-09-05 22:27

administrator   ~~0026963

Moved to https://github.com/multitheftauto/mtasa-blue/issues/393

Issue History

Date Modified Username Field Change