View Issue Details

IDProjectCategoryView StatusLast Update
0004059Multi Theft Auto : EditorMap Editorpublic2011-08-01 00:15
ReporterPaul_CortezAssigned ToarranTuna 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0004059: Make test mode only start for the player who pressed F5 or the test button.
Description

As the title says. It's not of an extreme importance, still it might be that you want to continue mapping while your friend wants to test the map.

This would be useful in for instance Race, where you might be unsure if the distance between a ramp and a piece of ground is too big or can be bigger.

Even if this would only work for the included standard test mode, it may avoid uncomfortable situations and create more comfortable situations. Possible fix to #4058.

TagsNo tags attached.

Activities

ryden

2009-03-06 12:12

manager   ~~0008476

This is a TODO for version 2.

Talidan

2009-03-06 12:15

administrator   ~~0008477

It has to be stressed that the test is global simply due to the nature that it works. It physically creates the map and starts the map resource in order to provide proper testing conditions. You cant do this on a per-player basis really.

Also, given that the editor starts tests with gamemodes its near impossible to encapsulate a gamemode test.

It might be possible to provide an alternative solution in future however.

[PS]DazzaJay[AU]

2009-08-03 21:19

reporter   ~~0010120

What about a Per-Player "Basic" test.
Where normal test mode (the current one) would still work how it does.

but a Basic test mode, where the player that put it into basic test is able to run around, and check stuff like Pickups, and "can i jump that high" while others are still working on the map. as in the ability to run around on the map while still being in the working dimension. thus a "Basic" test not a full test.

arranTuna

2011-07-29 14:20

developer   ~~0014047

I will use the above idea of a basic test, where editor mode is still running but you're able to go on foot on your own and test the map without disrupting others.

Picard

2011-07-30 17:46

updater   ~~0014057

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-resources/source/detail?r=758 )

Issue History

Date Modified Username Field Change