View Issue Details

IDProjectCategoryView StatusLast Update
0003626Multi Theft Auto : San AndreasGeneralpublic2009-08-23 01:58
ReporterIJsAssigned ToIJs 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0003626: Malfunctioning ID3DXFont::DrawText call
Description

A mysterious Direct3D malfunction (and resulting) after a ID3DXFont::DrawText call with the d3dx9_35.dll release redistributables.

0023fa80 030625ed d3dx9_35+0x1531ef
0023fae8 00000000 core!CGraphics::DrawTextA+0x15d [cgraphics.cpp @ 144]

Possible fix would be to omit BeginScene/EndScene calls.

Related entry: http://www.gamedev.net/community/forums/topic.asp?topic_id=301413

Assigned crash dump from user Jony during dp3 testing.

TagsNo tags attached.

Relationships

related to 0003055 closed Crash oddity after d3d Invalidate/Restore sequence (after initializing/splash screen) 
related to 0003625 closed Omit second BeginScene/EndScene Direct3D calls within same frame 

Activities

IJs

2008-05-30 17:11

administrator   ~~0007818

Last edited: 2008-05-30 17:11

Added some safeguards to CGraphics, notabily one that informs the user about any failures while loading the font objects. This should be re-tested by those affected.

jhxp

2008-12-22 12:50

administrator   ~~0008254

To be re-tested on 1.0 . If no such crashes occur again - set resolved/fixed on it.

Talidan

2009-02-08 02:30

administrator   ~~0008346

Closed unless reproduced under different circumstances. This was due to setting Compatibility mode to Windows 98, which will naturally cause issues for DX9.

Issue History

Date Modified Username Field Change