View Issue Details

IDProjectCategoryView StatusLast Update
0003625Multi Theft Auto : San AndreasGeneralpublic2013-04-20 21:41
ReporterIJsAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target Version1.3.3Fixed in Version 
Summary0003625: Omit second BeginScene/EndScene Direct3D calls within same frame
Description

We are currently calling BeginScene and EndScene a second time, before Present (event OnPresent). Because Direct3D does not allow multiple of these calls to be made before a single Present call, it is strongly recommended we reduce these calls to a single occurance.

This bug is possibly behind some unexplainable or rare Direct3D bugs or crashes that people have experienced.

This can be fixed by hooking in OnEndScene instead of OnPresent, but it involves clearing all states, transformations and what not before drawing our own stuff (this is the reason why the separate scene calls were used in the first place) - see revision 10720 that introduced several bugs.

TagsNo tags attached.

Relationships

related to 0003626 closedIJs Malfunctioning ID3DXFont::DrawText call 
related to 0003055 closed Crash oddity after d3d Invalidate/Restore sequence (after initializing/splash screen) 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change