View Issue Details

IDProjectCategoryView StatusLast Update
0003522Multi Theft Auto : San AndreasScriptingpublic2013-02-24 14:15
Reporterlil_ToadyAssigned ToJusonex 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version 
Summary0003522: request: Make it able to set velocity on dynamic objects
Description

^

TagsNo tags attached.

Relationships

has duplicate 0005735 closed New issues setElementVelocity works wrong for objects 
related to 0004893 resolvedJusonex Multi Theft Auto : San Andreas [Request] Implement events and functions for the manipulation of breakable objects 
child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Mr.Hankey

2010-03-22 23:19

reporter   ~~0011235

Having done some quick tests it looks like a player needs to touch the object before any velocity gets applied. This is always the case, even if it has been moved before and thus lost its resting state already.

lil_Toady

2010-10-17 20:34

administrator   ~~0012062

uint32 bUsesCollision : 1; // does entity use collision
uint32 bCollisionProcessed : 1; // has object been processed by a ProcessEntityCollision function
uint32 bHasContacted : 1; // has entity processed some contact forces
uint32 bIsStuck : 1; // is entity stuck
uint32 bIsInSafePosition : 1; // is entity in a collision free safe position
uint32 bWasPostponed : 1; // was entity control processing postponed

i guess playing around with those flags could solve the velocity not being applied before contacted by a player

Issue History

Date Modified Username Field Change