View Issue Details

IDProjectCategoryView StatusLast Update
0002566Multi Theft Auto : San AndreasScriptingpublic2007-11-26 18:06
ReporterRansomAssigned ToChrML 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0002566: On custom map, cars are not in place for player on join, even if frozen
Description

I'm not sure whats going on. I told my script to make vehicles you can buy that are indestructible and frozen. Yet, if you disconnect and come back, they are mysteriously not frozen in position and not indestructible. I see them under my custom map on top of the water if I drop thru the map where the vehicles were supposed to be.

This means theres two issues:

  1. For some reason frozen/indestructible vehicles aren't synced(?) for players who join (or d/c and rejoin). I notice that on server join the console says "> Starting resource 'x' for all the resources currently on.

  2. Cars placed on custom maps will fall through through the map due to the map not being streamed in yet for the player

I am working with 'cc'

TagsNo tags attached.

Relationships

parent of 0002502 closed Many animated objects frozen stiff now 

Activities

Talidan

2007-09-29 11:19

administrator   ~~0005841

I expect setting a vehicle to collisionless will also show these features

IJs

2007-09-29 14:23

administrator   ~~0005844

Possible fix was added today by Kevuwk.

Ransom

2007-09-29 15:39

administrator   ~~0005848

I have brought both of my pcs ingame to see if it was desync but both see the same thing. Its either screwed or not screwed for everyone. Its not only on a player joining, sometimes its just screwed up from the resource start, sometimes the vehicles never show up to begin with, which probably means sometimes vehicle froze / indestructible just isn't set for some reason and the cars fell through the map before I got there.

IJs

2007-10-06 09:19

administrator   ~~0005924

So let's see, you tested on the same day the fix was made: this means the fix was NOT incorporated into the build you were running.

Please test again.

Ransom

2007-10-13 23:14

administrator   ~~0005969

That comment was additional bug information to reproduce. I fail to see how that was seen as a test result. Tested today for first time, seems fixed. Need people to say if they fall through interstate when spawned on next test.

Ransom

2007-10-23 02:58

administrator   ~~0006053

Tested a couple times all worked, resolved until further problems arise

Ransom

2007-11-02 06:11

administrator   ~~0006118

Not resolved. Put destruction derby from race into dm and the vehicles fall through, the ones that are far away from me in particular.

You can test this out easily with mantis2566 resource, tweaks test servers

ChrML

2007-11-26 18:06

administrator   ~~0006469

Last edited: 2007-11-26 18:06

Fixed. Thanks for the mantis resource btw, made testing it easy.

Issue History

Date Modified Username Field Change