View Issue Details

IDProjectCategoryView StatusLast Update
0002448Multi Theft Auto : San AndreasMapspublic2013-10-28 14:33
ReporterjbetaAssigned Toryden 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformAMD Athlon(tm) 64 X2 ~2.2GHzOSWindows XP Professional x64 SP1OS Version5.2, Build 3790
Product Versionblue_sa.r2.a12 
Target Version1.0Fixed in Version1.0 
Summary0002448: Added objects aren't recognized as ground pieces
Description

Some consequences of this bug have been reported before, I'm grouping them under this one and closing them to reduce duplicates.

Steps To Reproduce
  • start a custom map such as cs_italy
  • spawn there
  • /crun getGroundPosition(4016,-1512,110)

It'll return 0, the water level, instead of the map's ground level.

TagsNo tags attached.

Relationships

parent of 0001980 resolvedryden Jetpack does not recognize added objects as ground pieces, cant get far off real ground 
parent of 0002439 resolvedryden Molotovs' snap-to-ground explosions don't work on placed objects 
related to 0001329 closedryden Player can "see through" created objects outside the game area 
related to 0002517 resolvedryden Created objects are slippery when walking on them 
child of 0001254 closedeAi Abnormalities in created objects 

Activities

IJs

2007-09-29 18:09

administrator   ~~0005860

I guess this is up to eAi.

Jax

2007-10-10 13:48

administrator   ~~0005955

Definitly not a block!

slothman

2007-10-11 09:50

updater   ~~0005959

the "isplayeronground" function also doesnt work while standing on placed objects

ChrML

2007-11-19 08:36

administrator   ~~0006385

GTA doesn't recognize custom objects as ground becuase they weren't really meant to be used as a map. We need to get buildings to work for static objects to get this working, which is postponed for a future release.

Talidan

2009-04-24 15:00

administrator   ~~0008901

I've reopened some of the child issues as they can be fixed individually (and not converting objects to CBuildings).

As far as getGroundPosition goes, im not sure its needed. processLineOfSight can replace this, and getPedContactElement can replace isPedOnGround.

Talidan

2009-04-24 18:10

administrator   ~~0008905

Also blood splatters dont work on objects. While this is minor, it affects fxAddBlood for example (which you can normally use to paint the floor).

lucasc190

2009-05-06 11:49

reporter   ~~0009052

What about adding "createBuilding" as a seperate function?

ata123456789

2013-10-28 12:31

viewer   ~~0019574

What about adding "createBuilding" as a seperate function?

Please, someone developer reply for this question.

JBoy

2013-10-28 13:52

viewer   ~~0019575

why add the function "createBuilding" when you could simply use createObject() ?

ata123456789

2013-10-28 14:25

viewer   ~~0019576

Because the object limit is higher for buildings than "normal" objects.

JBoy

2013-10-28 14:31

viewer   ~~0019577

object limitation is same for all objects (including buildings), correct?

Woovie

2013-10-28 14:33

manager   ~~0019578

createBuilding is a useless function. Buildings are objects. There would never be such a function.

Issue History

Date Modified Username Field Change