View Issue Details

IDProjectCategoryView StatusLast Update
0002003Multi Theft Auto : San AndreasMapspublic2007-05-06 05:16
ReporterslothmanAssigned ToIJs 
PriorityurgentSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Version 
Summary0002003: maps objects not loading
Description

this occurs almost always. custom elements that are stored in the map work fine, but objects themselves simply do not all load.

in my bmxstunt map, i have 11 regular objects. only one of them loads. it is consistantly the same object (the half pipe) am it isnt the first object in the .map file.

this also occurs in other maps, such as ransom's c&c map.

TagsNo tags attached.

Relationships

related to 0001271 resolvedccw Object limit increase 
related to 0001969 resolved Large objects can spin very fast or show huge stretched triangle textures 
child of 0001254 closedeAi Abnormalities in created objects 

Activities

jbeta

2007-05-05 06:17

updater   ~~0004484

It can happen with a large number of objects loaded, but it seems the missing objects aren't always the same ones here.

IJs

2007-05-05 07:58

administrator   ~~0004490

Presumably because of the lazy model loading. Should be fixed in the next build.

Ransom

2007-05-06 04:38

administrator   ~~0004511

Still major problems here. c&c_weapons couldnt even load almost an entire base or borders on the opposite side of the map from where you spawn. If the map object limit has really sunk this low then I'm very disappointed.

Can't there be a script function to optimize the streaming on a per-map basis?

IJs

2007-05-06 05:15

administrator   ~~0004512

Object streaming bug. Fixed in next nightly.

Issue History

Date Modified Username Field Change