View Issue Details

IDProjectCategoryView StatusLast Update
0001200Multi Theft Auto : San AndreasGeneralpublic2007-09-29 03:53
ReporterAlienXAssigned ToJax 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a4 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001200: Stuck on back after being jacked from a vehicle
Description

If you're in a vehicle and someone jacks you, you can get stuck on your back and can only spin around. You only get unstuck when you get hit by a car or jump.

Steps To Reproduce

1) Get in a tall vehicle (works very well in Monster)
2) Have someone jack you on the driver's side door
3) After the door is open but before you hit the ground, hold the "s" key (walk backwards)

TagsNo tags attached.

Relationships

related to 0001141 resolvedJax Driver is warped back into vehicle if jacking is aborted 
related to 0002547 resolvedJax Drivers get killed if a jacker holds/taps forward+jump whilst entering from passenger door 
related to 0002733 resolvedJax trying to enter boats or skimmer causes a glitch 

Activities

Talidan

2006-09-21 13:14

administrator   ~~0003507

this doesnt just occur in cars - havent seen it in a12 recently - but then again ive hardly been jacked

erorr404

2006-09-21 19:54

developer   ~~0003511

This happened to me a lot when getting jacked in today's test.

IJs

2007-01-21 19:05

administrator   ~~0003977

Please verify.

Solide

2007-01-25 03:13

reporter   ~~0004003

Afaik still happens, happened to me in vehicle banshee at 210107, during FPS lag caused by my crappy computer I got jacked.

Solide

2007-02-13 07:03

reporter   ~~0004050

bump

jhxp

2007-02-13 07:06

administrator   ~~0004051

This happens also on regular vehicles like Cheetah and Remington, as So'lide pointed out above.

erorr404

2007-02-17 19:18

developer   ~~0004058

Last edited: 2007-02-17 19:43

I warped to Slothman while I was dead, and got stuck under his bike. Spawning again got me unstuck. warpPlayerIntoVehicle should not warp dead players, then this particular bug won't happen.

http://www.thegamersalliance.com/Th!s_is_N0T_hidden_dir/mta-screen0047.jpg

erorr404

2007-03-12 20:48

developer   ~~0004157

The note above is actually a seperate bug, where the player is stuck under someone's bike, not just on the ground.

Jax

2007-03-29 04:55

administrator   ~~0004260

I think this happens when the jacker finishes getting into the vehicle before the jacked guy is standing (usually when theres a desync'd door), it calls RemoveFromVehicle while hes on the floor which breaks the animation.
Hard to reproduce so hard to test for a fix.
.."warpPlayerIntoVehicle should not warp dead players" doesnt anymore.

Jax

2007-04-01 06:47

administrator   ~~0004280

This should be fixed now, hard to reproduce, needs testing

norby89

2007-09-22 06:20

updater   ~~0005775

the way to reproduce this:

jack the vehicle from the passenger side (not sure if it happens ONLY from this side)
hold forward (all the time)
*press jump several times, you need to time it right because if you start pressing it too early entering will be aborted

this glitch has several effects, it can:

kill the driver
knock him to the ground, unable to move (as described by Monk)
knock the driver locally, you can see him sliding on his belly
cause major desync

Talidan

2007-09-26 17:39

administrator   ~~0005828

disable jump button while entering a vehicle task?

Jax

2007-09-29 03:53

administrator   ~~0005838

You shouldn't be able to jump whilst entering a vehicle anymore

Issue History

Date Modified Username Field Change